Product Notice #0344

Product Notice

New Service Pack for SIP Phone Support (SPS)

This Product Notice provides instructions on how to upgrade the SIP Phone Support (SPS) to resolve a bug in the SPS Switch component that sometimes causes the phone's BLF to stop functioning after the SPS Switch service resets.

The SPS Switch component is based on FreeSWITCH open source, which has a bug "Invalid Cseq Value Greater than 2^31 when sending NOTIFY" (https://freeswitch.org/jira/browse/FS-6806). This bug sometimes causes the phone's BLF to stop functioning after the SPS Switch service resets.

The bug fix was resolved in SPS Version 3.0.56. To upgrade the SPS, perform the following procedure:

  1. Check the SPS Switch component version through the SPS Web Admin, and then continue according to the version as listed below:
    • Version 3.0.56 or later: No need to perform this upgrade (bug has already been fixed in this version).
    • Version 3.0.25 or later but earlier than Version 3.0.56: Proceed to Step 2.
    • Earlier than Version 3.0.25: Upgrade the SPS to the latest version (Ver. 3.0.57), and then recheck the SPS Switch version to verify that the fix has been implemented. If not, proceed to Step 2.
  2. Download the SPS Switch component from https://downloads-audiocodes.s3.amazonaws.com/Miscellaneous/SPS-Switch-x64-3.0.56.44343-setup.exe.
  3. Run SPS-Switch-x64-3.0.56.44343-setup.exe on the SPS that you wish to upgrade and follow the on-screen instructions to install it.

Affected Products

AudioCodes SIP Phone Support (SPS)




»
  Download PDF version of this Product Notice  «

Support

If you have any questions, contact us at
www.audiocodes.com/corporate/offices-worldwide